DESKTOP PUBLISHING CLASS NOTES.

		A desktop publishing software popularly known as DTP is a specialized program used to create publications of professional quality using to create publications of professional quality using a Computer.

	DTP is used to create publications such as newsletters, text books, brochures, newspapers calendars and flyers. Popular DTP software includes Adobe PageMaker, Microsoft Publisher, QuarkXPress, Adobe In Design, Serif Page Plus and Apple Page 2.

ADVANTAGES OF DESKTOP PUBLICATION.

Every item on a page is contained in a frame and can be edited and formatted independently.

Stories can be contained in a single frame or threaded between several frames.

Frames need not flow in logical sequence. For example a story on page 1 may be continued on page 8.

Master pages are used to set a common layout which may be repeated on several pages. E.g Logo, page numbers.

Publication can be printed in a form suitable for commercial printing e.g using colour separations.

Wide range of templates is available e.g brochures, booklets, posters, business cards.

Multiple stories from different authors can be handled with ease.

COMMON FEATURES OF DTP SOFTWARE.

Most DTPs provide the user with a variety of tools for designing, manipulating and editing a publication.

Select Tool 	Used to select, move and resize images and text.

Text Tool	Used to draw text frames, insert and manipulate text.

Shapes Tools	For drawing basic shapes e.g rectangles and importing objects.

Zoom Tool	For magnifying publications view.

Rotate Tool	For rotating text or graphics.


STARTING PUBLISHER.

On the Start Menu, point to programs, Microsoft Office and then Click Microsoft Office Publisher.

Choose a design template or Click New to design from scratch.

On the File menu, Click Page Setup, select publication type and orientation.

On the Arrange menu, Click Layout Guides, Set margins and other properties.

Click the Ok button.

FEATURES OF PUBLISHER APPLICATION WINDOW.

Apart from the Title bar, Menu bar and Standard tool bar both DTPs have other features as shown.

Printable Area.	This resembles a typical piece of paper surrounded by margins. Objects to be printed must appear in the printable area.

Pasteboard.		This is a large blank space surrounding the printable area where objects are designed or edited before placing them on the printable area.

Rulers.			Measurements are important in publishing. A good DTP must have both horizontal and vertical rulers.

Master Page. 		These are the main pages used to design a common layout for a large publication .  You insert page numbers, headers and footers on the master pages.

Tool Box.		This contains a set of tools used to design and manipulate text and graphical objects.



TO SET UP A PUBLICATION IN PUBLISHER.

On the view menu,  Click Master page.

Use the Edit master pages toolbar to design a master page.

Switch back to foreground pages of the publication.

SAVING A PUBLICATION.

On the File menu, Click Save AS.
Select the drive or folder to save in.
Enter the File name then press enter.

WORKING WITH TEXT AND GRAPHICAL OBJECTS.
Adding Text.
 To add text using text or frame tool in publisher.

· Click the tool from the tool box.
· On the empty area on the paste board or printable area, drag to define the text block.
· Type the text.

RESIZING AND MOVING TEXT OBJECTS.
Text may not fit in the defined text frame do the following.
· Click the text block using  the pointer tool.
· Position the pointer on the selection handle and drag to resize.

TO MOVE THE TEXT BLOCK IN PUBLISHER.

· Click the text block using the pointer tool.
· Position the pointer tool on the object and hold down the left mouse button.
· Drag the text object to a new position.

IMPORTING TEXT FROM A WORD PROCESSOR.

· On the File menu, Click import word document.
· In the dialog box, select the file then click Ok.
· The text is pasted onto the printable area.


THREADING TEXT FRAMES.

	When a story in a frame or text block extends to another page or Column, It is broken into individual page or column blocks connected together. A plus sign at the top or bottom of a text block means that it is connected to a previous or next page or column. This is referred to as threading.

	If you add or delete text in a frame the rest of the story is pushed or moved to occupy the empty space.
Once text frames are threaded, you can easily redirect the flow of text through text frame.

TO THREAD TEXT FRAME IN PUBLISHER. 

· Click the first text box to select it, then Click create text box link button on the connect text boxes toolbar. The pointer changes to a pitcher.
· Click the text box you want to connect to. Text boxes that are connected will display the Go to next and Go to previous text boxes buttons in the corner of each box.
· Use connected text boxes to continue s story or move overflow text into the next text box.

CREATING BASIC SHAPES.
This feature allows the user to create basic shapes such as lines, eclipses, rectangles and other polygons using the drawing tools on the toolbox.
To draw basic shapes:
· Select a Shape.
· Position the tool where you want to draw the shape.
· Hold down the left mouse button and drag the shape to the required size.
· You can then fill the shape with any pattern and colour.

INSERTING GRAPHICAL OBJECTS.

You can as well import pictures and other graphical objects are of different formats. Some common formats are:

Post Script	Vector graphics created using drawing programs, such as Adobe Illustrator, Adobe Free hand and Corel Paint.

Tagged	Image file format (tisf) screen   images, scanned photos. Tisf images takes up a lot of storage space.

Joint picture extension graphic (jpeg) and Graphical Interface Format (gif).
These are mainly used on internet and digital cameras because they take up small storage space.

Windows meta file (wmf) and windows Paint brush files (pcx).

TO IMPORT AN OBJECT IN PUBLISHER.
To import an object in Publisher.
· On the Insert menu, point to picture, Click from File.
· In the Insert picture, dialog box, select the drive or folder where the file is located.
· Click the file then insert

Object linking and embedding (OLE).

	In Desktop Publishing, OLE refers to a technology where an Object can be shared by more than one application.
	If an Object is linked to the source file any changes made at the source are replaced in all applications where a link exists. The destination file stores an image or copy of the source file.
	On the other hand if an object is embedded no direct link exists. The embedded object becomes part of the destination file and updates on the source file do not appear on the embedded.

	To embed or link an object to publisher.

· On the Edit menu, Click Insert Object.
· In the dialog box displayed, Click creates from the file.
· Click the Browse button to select the file you want to link or embed.
· To create a link, make sure link checkbox is checked.
· Click Ok.

Editing, Formatting.
 You may want to delete some text or an entire text object. To delete  text in Publisher.

· Click the text tool and highlight the text.
· Press the Delete or Backspace key.
To delete  a text object.
· Click the pointer tool then click the text frame.
· Press the delete or backspace key.

Copying and moving a block of text.
· Select the block of text.
· On the File menu, Click copy or cut.
· Click where you want to paste the text.
· On Edit menu, click paste.

Spell Checking a Publication.
A publication may consist of one or several text frames called stories. To spell check a publication   in Publisher.
· On the Tools menu, point to spelling then Click spelling.
· In the dialog box, mark  check all stories.
· Replace or ignore the misspelled words.
· Click OK to close.


Find and Replace.
To search for a word or phrase in Publisher.
· On the Edit menu, Click Replace to display dialog box.
· In the Find what box type the words to be searched.
· In the Replace with box, type the words to replace the found words.
· Click Replace/Replace All Button.

Editing the Layout.
 To edit a publication layout in publisher.
· Switch to the master page.
· Make the necessary changes then switch to the foreground pages.

Editing Graphical Objects.
Graphical Objects are clip arts and pictures. You edit an object’s attributes such as size, position, colour and brightness.

Moving and resizing objects.
To resize an object in Publisher.
· Select the shape using the pointer tool.
· To resize, place the mouse pointer on the place sizing handles then drag.
· To move, place the mouse pointer on the shape then drag to the required place.



CHANGING PICTURE ATTRIBUTES.
A picture or Clipart attributes include content, colour mode and brightness.
To edit an object attributes in Publisher.
· Select the object.
· Display picture toolbar.
· Adjust the required attributes.

Formatting a Publication.

· Highlight the text to format.
· On thee formatting tool bar, choose font style, size and other attributes.

Changing case.

· Highlight the text.
· On the utilities menu point to plug-in then click change case.
· Select case type as in, then click OK.

Tracking and Kerning. 
 Tracking refers to the visual denseness between all text characters while kerning is fixing the space between a pair of characters.

To adjust Tracking.

· Highlight the text.
· On the Format menu, click Character spacing.
· In the dialog box, adjust tracking.

To adjust kerning in Publisher.

· Highlight the pair of characters.
· On the format menu, click Character spacing.
· Under kerning, select Expand or Condense.

Superscript and Subscript.

· Highlight the text.
· On the Format menu, mark the Superscript or Subscript.
· Click Ok button.



Paragraph  and page formatting.

Paragraph formatting involve aligning text, indenting adding column guides, inserting headers and footers.

Text  Alignment.
Text can be aligned to the left, right, centre or justified along the left and right margins.  To align  text in publisher.

· Highlight the text.
· On the formatting toolbar, click left, centre, right or justify button.

Indent and Tabs.

Indent move text inward from the left or right margin, while tabs are used to define where a tab stops when you press the tab key. To set tabs and Indent in Publisher.

· On the Format menu, click tabs to set tab stop or indent and list to set indent.
· In the dialog box, set the required tab stop.
· To indent , Click increase/ decrease indent button on the toolbar.

Inserting Column Guides.
A page by default is made of one column. To create more than one column do the following.

· On the Arrange menu, click layout Guides.
· In the dialog box, enter number of columns required then click OK.

Headers and Footers.
Headers are lines of text, page numbers or date that appears at the top of every page. Footers on the other hand appear at the bottom of every page. 
To insert Headers and Footers.

· Switch to master pages.
· On the view menu, click  Headers and Footer.
· To insert page numbers, click page numbers from the insert menu.
· To insert text, create a text frame then type in text.


Fill and Stroke.
Filling refers to applying a solid colour or patterns to a drawing while stroke refers to the outline style.
To apply background and stroke in Publisher.
· Select the Object.
· On the format menu, click Auto shapes.
· In the dialog box, select fill effect and boarder style.

Rotating an Object.
· Select the Object.
· Hold down CTRL key and drag the green rotation handle. Alternatively from the Arrange menu, point to Rotate or Flip. On the dialog box, select the option you want.
· Rotate the handle in clockwise or anticlockwise direction.

Arranging Objects.
· Select the Object while pressing Shift+ Tab keys.
· On the Arrange menu, point to order.
· Select an arrange option from the list.

Cropping Graphical Object.

Cropping is clipping or cutting off unwanted parts of a graphical object particularly a picture. To crop an object in Publisher.

· Select the Object.
· On the picture tool bar, click the crop tool.
· Position the cropping tool over  a placeholder on the object and drag inward.

Grouping Objects.
If you have several objects in a publication you may want to group them together. To group objects in publisher.

· Hold down the Shift key as you click each object.
· Right click the selection then click group.

Wrapping text around an object.
 Text may be wrapped around an object to wrap text .
· Select both objects placed on the text frame.
· On the format menu, click Picture.
· In the dialog box, click layout tab and then select a wrapping style.





Printing  A Publication.

Unlike in other application programs, printing in DTP is more technical. This is because you may prefer to print a picture in separate colours refferd to as colour separation. You can also show crop marks and other details required for commercial printing.

To Print A Publication in Publisher.
· On the File Menu, Click Print.
· Click Properties button to set print options.
· In the print dialog box, click he Advanced print setting button.
· Click the separation tab.
· In the output list, click separations to process Cyan, Magenta, yellow and Black (CMYK) separately.
· Click OK.
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